jQuery 1.3参考手册

核心

  • jQuery 核心函数

    • jQuery(expr, [context])
    • jQuery(html, [ownerDoc])
    • jQuery(elements)
    • jQuery(callback)

  • jQuery 对象访问

    • each(callback)
    • size()
    • length
    • selector
    • context
    • get()
    • get(index)
    • index(subject)

  • 数据缓存

    • data(name , [value])
    • removeData(name)
    • queue(name ,[cb| queue])
    • dequeue(name)

  • 插件机制

    • jQuery.fn.extend(object)
    • jQuery.extend(object)

  • 多库共存

    • jQuery.noConflict([extreme])

属性

  • 属性

    • attr(name)
    • attr(properties)
    • attr(key, value)
    • attr(key, fn)
    • removeAttr(name)

  • CSS 类

    • addClass(class)
    • removeClass([class])
    • toggleClass(class [, switch])

  • HTML代码

    • html( [val] )

  • 文本

    • text( [val] )

  • 值

    • val( [val] )

CSS

  • CSS

    • css(name)
    • css(properties)
    • css(name, value)

  • 位置

    • offset()
    • position()
    • scrollTop( [val] )
    • scrollLeft( [val] )

  • 尺寸

    • height( [val] )
    • width( [val] )
    • innerHeight()
    • innerWidth()
    • outerHeight(options)
    • outerWidth(options)

选择器

  • 基本

    • #id
    • element
    • .class
    • *
    • selector1,selector2,selectorN

  • 层级

    • ancestor descendant
    • parent > child
    • prev + next
    • prev ~ siblings

  • 基本

    • :first
    • :last
    • :not
    • :even
    • :odd
    • :eq
    • :gt
    • :lt
    • :header
    • :animated

  • 内容

    • :contains
    • :empty
    • :has
    • :parent

  • 可见性

    • :hidden
    • :visible

  • 属性

    • [attribute]
    • [attribute=value]
    • [attribute!=value]
    • [attribute^=value]
    • [attribute$=value]
    • [attribute*=value]
    • [attrSel1][attrSel2][attrSelN]

  • 子元素

    • :nth-child
    • :first-child
    • :last-child
    • :only-child

  • 表单

    • :input
    • :text
    • :password
    • :radio
    • :checkbox
    • :submit
    • :image
    • :reset
    • :button
    • :file
    • :hidden

  • 表单对象属性

    • :enabled
    • :disabled
    • :checked
    • :selected

文档处理

  • 内部插入

    • append(content)
    • appendTo(content)
    • prepend(content)
    • prependTo(content)

  • 外部插入

    • after(content)
    • before(content)
    • insertAfter(content)
    • insertBefore(content)

  • 包裹

    • wrap(html)
    • wrap(elem)
    • wrapAll(html)
    • wrapAll(elem)
    • wrapInner(html)
    • wrapInner(elem)

  • 替换

    • replaceWith(content)
    • replaceAll(selector)

  • 删除

    • empty()
    • remove([expr])

  • 复制

    • clone()
    • clone(true)

筛选

  • 过滤

    • eq(index)
    • hasClass(class)
    • filter(expr)
    • filter(fn)
    • is(expr)
    • map(callback)
    • not(expr)
    • slice(start, [end])

  • 查找

    • add(expr)
    • children([expr])
    • closest([expr])
    • contents()
    • find(expr)
    • next([expr])
    • nextAll([expr])
    • offsetParent()
    • parent([expr])
    • parents([expr])
    • prev([expr])
    • prevAll([expr])
    • siblings([expr])

  • 串联

    • andSelf()
    • end()

事件

  • 页面载入

    • ready(fn)

  • 事件处理

    • bind(type, [data], fn)
    • one(type, [data], fn)
    • trigger(type, [data])
    • triggerHandler(type, [data])
    • unbind([type], [data])

  • 事件委派

    • live(type, fn)
    • die([type], [fn])

  • 事件切换

    • hover(over, out)
    • toggle(fn, fn2, [fn3, fn4, ...])

  • 事件

    • blur( [fn] )
    • change( [fn] )
    • click( [fn] )
    • dblclick( [fn] )
    • error( [fn] )
    • focus( [fn] )
    • keydown( [fn] )
    • keypress( [fn] )
    • keyup( [fn] )
    • mousedown(fn)
    • mousemove(fn)
    • mouseout(fn)
    • mouseover(fn)
    • mouseup(fn)
    • resize(fn)
    • scroll(fn)
    • select( [fn] )
    • submit( [fn] )
    • unload(fn)

效果

  • 基本

    • show()
    • show(speed, [callback])
    • hide()
    • hide(speed, [callback])
    • toggle()
    • toggle(switch)
    • toggle(speed, [callback])

  • 滑动

    • slideDown(speed, [callback])
    • slideUp(speed, [callback])
    • slideToggle(speed, [callback])

  • 淡入淡出

    • fadeIn(speed, [callback])
    • fadeOut(speed, [callback])
    • fadeTo(speed, opacity, [fn])

  • 自定义

    • animate(param,[dur],[e],[fn])
    • animate(params, options)
    • stop([clearQueue], [gotoEnd])

  • 设置

    • jQuery.fx.off

Ajax

  • Ajax 请求

    • $.ajax([options])
    • load(url, [data], [callback])
    • $.get(url, [data], [fn], [type])
    • $.getJSON(url, [data], [fn])
    • $.getScript(url, [callback])
    • $.post(url, [data], [fn], [type])

  • Ajax 事件

    • ajaxComplete(callback)
    • ajaxError(callback)
    • ajaxSend(callback)
    • ajaxStart(callback)
    • ajaxStop(callback)
    • ajaxSuccess(callback)

  • 其它

    • $.ajaxSetup([options])
    • serialize()
    • serializeArray()

工具

  • 浏览器及特性检测

    • $.support
    • $.browser
    • $.browser.version
    • $.boxModel

  • 数组和对象操作

    • $.each(object, [callback])
    • $.extend([d],tgt,obj1,[objN])
    • $.grep(array, fn, [invert])
    • $.makeArray(obj)
    • $.map(array, callback)
    • $.inArray(value, array)
    • $.merge(first, second)
    • $.unique(array)

  • 测试操作

    • $.isArray(obj)
    • $.isFunction(obj)

  • 字符串操作

    • $.trim(str)

  • URL

    • $.param(obj)